Bez tytułu

z Funky Ostrich, 3 miesiące temu, napisane w Plain Text, wyświetlone 56 razy. [paste_expire] 7 miesiące.
URL https://pastebin.k4be.pl/view/ac9b4155 Udostępnij
Pobierz wklejkę lub Pokaż surowy tekst
  1.  # emerge -vpDNu @world --backtrack=9999
  2.  
  3. These are the packages that would be merged, in order:
  4.  
  5. Calculating dependencies... done!
  6.  
  7. !!! Multiple package instances within a single package slot have been pulled
  8. !!! into the dependency graph, resulting in a slot conflict:
  9.  
  10. dev-lang/perl:0
  11.  
  12.   (dev-lang/perl-5.34.1-r3:0/5.34::gentoo, ebuild scheduled for merge) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" pulled in by
  13.     (no parents that aren't satisfied by other packages in this slot)
  14.  
  15.   (dev-lang/perl-5.30.3:0/5.30::gentoo, installed) USE="berkdb gdbm -debug -doc -ithreads" pulled in by
  16.     dev-lang/perl:0/5.30= required by (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, installed) USE=""
  17.                  ^^^^^^^^
  18.  
  19. app-arch/xz-utils:0
  20.  
  21.   (app-arch/xz-utils-5.2.5-r2:0/0::gentoo, ebuild scheduled for merge) USE="extra-filters nls (split-usr) -static-libs -verify-sig" pulled in by
  22.     (no parents that aren't satisfied by other packages in this slot)
  23.  
  24.   (app-arch/xz-utils-5.2.5:0/0::gentoo, installed) USE="extra-filters nls (split-usr) threads -static-libs" pulled in by
  25.     app-arch/xz-utils[threads] required by (app-arch/libarchive-3.5.1:0/13::gentoo, installed) USE="acl bzip2 e2fsprogs iconv lzma threads xattr zlib -blake2 -expat -libressl -lz4 -lzo -nettle -static-libs -zstd"
  26.                       ^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                            
  27.  
  28. sys-libs/ncurses:0
  29.  
  30.   (sys-libs/ncurses-6.3_p20220423:0/6::gentoo, ebuild scheduled for merge) USE="cxx (split-usr) (tinfo) -ada -debug -doc -gpm -minimal -profile -static-libs -test -trace -verify-sig" pulled in by
  31.     (no parents that aren't satisfied by other packages in this slot)
  32.  
  33.   (sys-libs/ncurses-6.2-r1:0/6::gentoo, installed) USE="cxx (split-usr) (tinfo) unicode -ada -debug -doc -gpm -minimal -profile -static-libs -test -threads -trace" pulled in by
  34.     sys-libs/ncurses:0/6=[unicode] required by (sys-process/htop-3.0.2:0/0::gentoo, installed) USE="unicode -openvz -vserver"
  35.                           ^^^^^^^
  36.  
  37.  
  38. !!! The slot conflict(s) shown above involve package(s) which may need to
  39. !!! be rebuilt in order to solve the conflict(s). However, the following
  40. !!! package(s) cannot be rebuilt for the reason(s) shown:
  41.  
  42.   (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, installed): ebuild is masked or unavailable
  43.  
  44.  
  45. It may be possible to solve this problem by using package.mask to
  46. prevent one of those packages from being selected. However, it is also
  47. possible that conflicting dependencies exist such that they are
  48. impossible to satisfy simultaneously.  If such a conflict exists in
  49. the dependencies of two different packages, then those packages can
  50. not be installed simultaneously.
  51.  
  52. For more information, see MASKED PACKAGES section in the emerge man
  53. page or refer to the Gentoo Handbook.
  54.  
  55.  
  56. The following USE changes are necessary to proceed:
  57.  (see "package.use" in the portage(5) man page for more details)
  58. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  59. >=dev-python/setuptools-62.3.3 python_targets_python3_8
  60. # required by dev-python/setuptools-62.3.3::gentoo
  61. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  62. >=dev-python/appdirs-1.4.4-r2 python_targets_python3_8
  63. # required by dev-python/setuptools-62.3.3::gentoo
  64. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  65. >=dev-python/jaraco-text-3.7.0-r2 python_targets_python3_8
  66. # required by dev-python/nspektr-0.3.0::gentoo
  67. # required by dev-python/setuptools-62.3.3::gentoo
  68. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  69. >=dev-python/more-itertools-8.13.0 python_targets_python3_8
  70. # required by dev-python/setuptools-62.3.3::gentoo
  71. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  72. >=dev-python/nspektr-0.3.0 python_targets_python3_8
  73. # required by dev-python/setuptools-62.3.3::gentoo
  74. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  75. >=dev-python/ordered-set-4.1.0 python_targets_python3_8
  76. # required by dev-python/nspektr-0.3.0::gentoo
  77. # required by dev-python/setuptools-62.3.3::gentoo
  78. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  79. >=dev-python/packaging-21.3-r2 python_targets_python3_8
  80. # required by dev-python/setuptools-62.3.3::gentoo
  81. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  82. >=dev-python/tomli-2.0.1 python_targets_python3_8
  83. # required by dev-python/nspektr-0.3.0::gentoo[python_targets_python3_8,python_targets_python3_9]
  84. # required by dev-python/setuptools-62.3.3::gentoo
  85. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  86. >=dev-python/importlib_metadata-4.11.3 python_targets_python3_8
  87. # required by dev-python/jaraco-text-3.7.0-r2::gentoo[python_targets_python3_8]
  88. # required by dev-python/setuptools-62.3.3::gentoo
  89. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  90. >=dev-python/importlib_resources-5.7.1 python_targets_python3_8
  91. # required by dev-python/setuptools-62.3.3::gentoo
  92. # required by dev-python/setuptools_scm-6.4.2::gentoo
  93. =dev-python/certifi-3021.3.16-r2 python_targets_python3_8
  94. # required by dev-python/setuptools-62.3.3::gentoo
  95. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  96. >=dev-python/setuptools_scm-6.4.2 python_targets_python3_8
  97. # required by dev-python/setuptools-62.3.3::gentoo
  98. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  99. >=dev-python/wheel-0.37.1-r1 python_targets_python3_8
  100. # required by dev-python/jaraco-functools-3.5.0-r2::gentoo
  101. # required by dev-python/jaraco-text-3.7.0-r2::gentoo
  102. # required by dev-python/setuptools-62.3.3::gentoo
  103. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  104. >=dev-python/gpep517-6 python_targets_python3_8
  105. # required by dev-python/gpep517-6::gentoo
  106. # required by dev-python/appdirs-1.4.4-r2::gentoo
  107. # required by dev-python/setuptools-62.3.3::gentoo
  108. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  109. >=dev-python/installer-0.5.1 python_targets_python3_8
  110. # required by dev-python/ordered-set-4.1.0::gentoo
  111. # required by dev-python/setuptools-62.3.3::gentoo
  112. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  113. >=dev-python/flit_core-3.7.1 python_targets_python3_8
  114. # required by dev-python/importlib_resources-5.7.1::gentoo[python_targets_python3_8]
  115. # required by dev-python/jaraco-text-3.7.0-r2::gentoo[python_targets_python3_8]
  116. # required by dev-python/setuptools-62.3.3::gentoo
  117. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  118. >=dev-python/zipp-3.8.0 python_targets_python3_8
  119. # required by dev-python/packaging-21.3-r2::gentoo
  120. # required by dev-python/nspektr-0.3.0::gentoo
  121. # required by dev-python/setuptools-62.3.3::gentoo
  122. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  123. >=dev-python/pyparsing-3.0.9 python_targets_python3_8
  124. # required by dev-python/nspektr-0.3.0::gentoo
  125. # required by dev-python/setuptools-62.3.3::gentoo
  126. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  127. >=dev-python/jaraco-context-4.1.1-r2 python_targets_python3_8
  128. # required by dev-python/nspektr-0.3.0::gentoo
  129. # required by dev-python/setuptools-62.3.3::gentoo
  130. # required by dev-python/certifi-3021.3.16-r2::gentoo[-test]
  131. >=dev-python/jaraco-functools-3.5.0-r2 python_targets_python3_8
  132.  
  133.  * In order to avoid wasting time, backtracking has terminated early
  134.  * due to the above autounmask change(s). The --autounmask-backtrack=y
  135.  * option can be used to force further backtracking, but there is no
  136.  * guarantee that it will produce a solution.
  137.  
  138. !!! All ebuilds that could satisfy ">=dev-util/meson-0.59.4" have been masked.
  139. !!! One of the following masked packages is required to complete your request:
  140. - dev-util/meson-9999::gentoo (masked by: EAPI 8)
  141. - dev-util/meson-0.62.2::gentoo (masked by: EAPI 8)
  142. - dev-util/meson-0.62.1::gentoo (masked by: EAPI 8)
  143. - dev-util/meson-0.61.4-r2::gentoo (masked by: EAPI 8)
  144. - dev-util/meson-0.60.3::gentoo (masked by: EAPI 8)
  145.  
  146. The current version of portage supports EAPI '7'. You must upgrade to a
  147. newer version of portage before EAPI masked packages can be installed.
  148. (dependency required by "dev-libs/libgudev-237-r1::gentoo" [ebuild])
  149. (dependency required by "sys-power/upower-0.99.11::gentoo" [installed])
  150. (dependency required by "@selected" [set])
  151. (dependency required by "@world" [argument])
  152. For more information, see the MASKED PACKAGES section in the emerge
  153. man page or refer to the Gentoo Handbook.

odpowiedź "Bez tytułu"

Tutaj możesz odpowiedzieć na wklejkę z góry

captcha